CocoaPods

一.作用

CocoaPods 是开发 OS X 和 iOS 应用程序的一个第三方库的依赖管理工具。利用 CocoaPods,可以定义自己的依赖关系 (称作 pods),并且随着时间的变化,以及在整个开发环境中对第三方库的版本管理非常方便。

CocoaPods可以帮助开发者

  • 下载开源库的源代码并引入工程
  • 向工程中添加开源库使用到的framework
  • 解决开源库和开源库以及开源库和工程之间的依赖关系、检查重复添加的framework等问题
  • 可以方便更新开源库,及其相应的其他更新。

可以让开发者自动化的、集中的、直观的管理第三方开源库。为项目开发节省时间,减少繁杂。

二.安装

mac下自带Ruby环境,所以直接在终端敲如下命令

sudo gem install cocoapods

由于在国内被墙住,无法访问到cocoapods.org,所以替换淘宝的Ruby镜像来访问cocoapods,按照下面顺序依次敲入命令:

$ gem sources --remove https://rubygems.org/
//等有反应之后再敲入以下命令
$ gem sources -a https://ruby.taobao.org/
//http的已经停止,改成https
为了验证你的Ruby镜像是taobao,可用如下命令查看:

gem sources -l

只用在终端出现下面的文字才表明之前的命令执行成功

*** CURRENT SOURCES ***

http://ruby.taobao.org/

如果没有出现taobao的网站,或者为空,重新执行上一步命令。
完成以上步骤后,重新执行

sudo gem install cocoapods

等待一段时间后,cocoapods就可以在你本地下载并且安装好,不需要其他设置

三.使用

新建Podfile文件

vim Podfile 

Podfile文件内容可以参考官网

platform :ios, '8.0'
use_frameworks!

target 'MyApp' do
  pod 'AFNetworking', '~> 2.6'
  pod 'ORStackView', '~> 3.0'
  pod 'SwiftyJSON', '~> 2.3'
end

pod ‘第三方库’ ‘版本号’,下载指定版本,如果没有版本号默认下载最新版本库。’~> 2.6’下载版本号为>=2.6.0 <2.7的版本。

文件的注释 ,单行注释: #
多行注释如下:

  =begin    

codes to comment 

  =end

可以通过 “pod search 库名 ” 查询第三方库的信息。

然后执行命令,下载配置第三方库。

pod install

完成后应用打开方式发生变化。需要打开App.xcworkspace文件打开工程,如果按照原来方式打开工程会报错。如果打开后发现工程文件无法展开,检查Podfile文件中的target 指向的名称是否和工程名一致。
有时候如果pods不是最新版本也会报错,但是报错会提示解决办法,根据提示执行

gem install cocoapods --pre

最新动态请参照CocoaPods 官网